Cylinder 1 idle stumble and advanced

Hyab00sta

Lurker
Nov 19, 2018
14
I have a 335xi ST stock coils and NGK 1 step colder plugs. cylinder 1 coil started going and misfiring so i swapped coil and plug and verified it followed the coil and plug became fouled as a result. Installed and old but good plug and coil and got it back to my shop and car was running fine but at idle cylinder one ignition was a little jumpy at idle and during cruising at steady throttle it would stick at 33.3 while all other cylinders were at 4.7. i figured it may be the old oem spark plug i was using in the meantime.

Upgraded my coils to Precision and NGK 97506 gaped to 0.22. Still have the same condition with cylinder 1 all afr in bank one and 2 look stable. When i accelerate and give it over 1/4 throttle or full all the cylinders fall in line and hold correct timing with no variances across all 6 cylinders. Anyone experience anything like this before or any ideas? maybe a bad spray pattern in the cylinder 1 injector? cant imagine a leaky injector or my afr's would be off no? thanks

https://datazap.me/u/hyaboosta/ignition-1?log=0&data=1-4-9-11-25
 

Hyab00sta

Lurker
Nov 19, 2018
14
Starting to suspect the injector leaking in cylinder 1. When I replaced the spark plugs they had 15k miles on them and 1 and 2 were running a lot more rich than the rest. The idle is a lot rougher on cold starts and clears up as it warms up and I get a faulty low fuel pressure sensor code on cold start only as well. i'm guessing the leaky injector could be leaking line pressure out to zero and it throws the fault because of having zero pressure on start up.(sensor was replaced 30k ago as well).
 
Top