Discussion about issues encountered whilst converting to M3 Flash and GWS

RSL

Sergeant
Aug 11, 2017
441
I'm probably one of the few people still working right now. 60.1 should be fine. Clean install and make sure date is correct in the VO (i.e. not before that DSC was in use).
 
  • 1Like
Reactions: Begood69

Begood69

Specialist
Nov 13, 2016
83
Fayetteville, NC
Getting closer. So yesterday. I was troubleshooting with Roma a guy the swapped and dct into a 2007 at after doing a mt swap and have 0 issues. M button and all. He help me figured one of my issues. The gws was not lighting up and was not showing on my coding. It was the ptcan wires that were crossed. In case this happens to any one. Now time to continue troubleshoot.
M3DSC AND M3SZL are not pairing. The dsc is an MK60E5 and the szl is the zb#... 060 with MDM and rain sensor.
I am wondering if it requires repining or one of the plugs in the szl? Turnsignal, highbeams, paddles, and bc buttons works. Not wippers, steering wheel buttons. Jbe is going crazy with the wipers working.

Ideas or solutions?

I did checked VO date 0910.
I am using PK91 productionline
I did swap the speed sensors for m3 sensors, no change on codes.
 

Attachments

Last edited:

Begood69

Specialist
Nov 13, 2016
83
Fayetteville, NC
Well i tried to connect to the dsc for coding using protools. It seems like it works.. but on all the selections the app gave me errors,so i assume is not coding. I tried to use ncsexpert and it does not give me the choice of the ecu to play with nor the jobs. It gives me a code 1000. Help.
 

Attachments

Begood69

Specialist
Nov 13, 2016
83
Fayetteville, NC
Hello Guys,

Ive done with 95% of the Electric Part of Convertation:

GWS
EDC/Power button
Drivelogic Button
M3 SZL
M3 Steering with Paddels & MuFu
M3 Combi
M3 DSC MK60

Wiring is Done, Wires to MK60 and to MSD81 are installed.


flashed the M3 GTS Software
flashed the 1er M Software (IKM0S)
Coded the VO for M Drive and M DCT
Coded the M3DSC, Kombi, CIC, MSD81 and GWS



i thing all is installed except the4 M3 DSC Sensors, are they necessary?

Other Quetion, does the M3 LSD Fit with the 335i driveshafts? someone say yes, other say no.

Edit: no Error Codes, DSC OFF is Work, M button Work (Green M Light Turned On) Power Bottun no funktion (No change and no Light turned on after push) iDrive Changes in M Display (CIC) dont work
I am having issues getting dsc and szl pairing, help please?
 

Attachments

RSL

Sergeant
Aug 11, 2017
441
Maybe try a normal M3 code? CRT/GTS has some specific files and modules/coding/pins may not be the same as normal M3s. Don't jump into the deep end to start, make it as easy as possible to get working as intended and then mess around with the questionable options after if you want.
 
  • 1Like
  • 1Informative
Reactions: Begood69 and aus335iguy

Begood69

Specialist
Nov 13, 2016
83
Fayetteville, NC
Maybe try a normal M3 code? CRT/GTS has some specific files and modules/coding/pins may not be the same as normal M3s. Don't jump into the deep end to start, make it as easy as possible to get working as intended and then mess around with the questionable options after if you want.
I did try the PM91. But was no diff, actually was like most of the coding was done, all cic and kombi options were selected. What i do not understand is the szl serial invalid code. 🤔
 

RSL

Sergeant
Aug 11, 2017
441
The only other thing I can think is that the files it's using aren't correct based on the selection or dates. Might try running through files in Tools32 and see which, if any, can read the DSC or EGS or if there is a comm error before you even get that far.
 

Begood69

Specialist
Nov 13, 2016
83
Fayetteville, NC
The only other thing I can think is that the files it's using aren't correct based on the selection or dates. Might try running through files in Tools32 and see which, if any, can read the DSC or EGS or if there is a comm error before you even get that far.
After a few hrs or troubleshooting.. figured out with help of Roma in Europe that one of my VO values was conflicting. After we identified it NCS expert is back online. So fixing my VO got me a step closer. CORRECTED
Next we found out my pining of the yaw pin1 does not go to pin 28 on dsc but to pin 26. CORRECTED then i was able to default code my M3DSC. But not able to code the M3SZL.
Next we found that F-CAN had an issue. Next is troubleshooting that part tomorrow. Anyone input?
 

RSL

Sergeant
Aug 11, 2017
441
Progress at least. I've seen SZL is coded through DSC, including M3 (MK60_M3.xxx). Do you have a separate "M3SZL" module listed with the VO you're using?
 

LMB335is

Sergeant
Apr 12, 2017
275
FOB FL
After a few hrs or troubleshooting.. figured out with help of Roma in Europe that one of my VO values was conflicting. After we identified it NCS expert is back online. So fixing my VO got me a step closer. CORRECTED
Next we found out my pining of the yaw pin1 does not go to pin 28 on dsc but to pin 26. CORRECTED then i was able to default code my M3DSC. But not able to code the M3SZL.
Next we found that F-CAN had an issue. Next is troubleshooting that part tomorrow. Anyone input?

There's no separate SZL module, it's coded as part of the DSC. What do you mean by code the SZL? Are you trying to do the SAS?
 
Top