Markyb0s Single Turbo Build

  • Login or Register, members don't see Ads!
  • Tip: You can toggle the Dark Theme at the bottom of the page

markyb0

Specialist
Jun 17, 2017
96
Hampton, VA
Got the new advs sensors installed working like a charm. Went out to do some test pulls and boost went way way over target. Going to let my car cool down then check the wastegate plumbing see if I messed up. I'll attach the csv files for you guys to look at and try to help me please. Other then that car is running way better with the new sensors in.
 

Attachments

doublespaces

Administrator
Oct 18, 2016
7,927
AZ
Did you have your tune changed for them? I think the adv setting in MHD is for jb4 backend flash people or something. Not sure how it will work with your car, do you have a custom tune?
 

markyb0

Specialist
Jun 17, 2017
96
Hampton, VA
I want to get it tuned but I need to get it to "pass" smog and register it before I put anymore money into it. And get new tires to. Just keeps taking my money lol.
 

doublespaces

Administrator
Oct 18, 2016
7,927
AZ
K. Someone else would have to chime in but I heard that setting was for jb4 backend flash guys but idk. Maybe it works with what you've got. Somebody must be tuning the car, so are you on a bad tune of what?
 

markyb0

Specialist
Jun 17, 2017
96
Hampton, VA
Well bringing this old thread back to life. Work has had me away for 8+ months and finally reunited with my car. Moved from San Diego to Hampton Virginia. Shipping two cars coast to coast has taken all my money for now lol. Well I knew when I put my car in storage there was a oil leak in the valve cover gasket. So as soon as my car made it to Virginia last week I tore it apart and replaced the gasket. Of course it could not be that easy. Pretty sure its the valve cover it self now. After driving it just down the street and back there was already some oil slowing leaking onto the headers again and smoking. Also before I put my car in storage i put it in a non driving status to save money and now I need to get it smogged again to register it. So that's some more money i need to throw at it before I can start driving it again. I've been reading on on how pass emissions with a single setup and I'm a little confused. If someone can chime in that would be much appreciated.
 
  • 1Like
Reactions: doublespaces

markyb0

Specialist
Jun 17, 2017
96
Hampton, VA
Since I had to remove the turbo and everything was out of the way I ended up using some of the leftover Dei wrap and wrapped the A/C lines, Oil feed line, oil drain, and my o2 sensors. Definitely don't like how it turned out but its what I had laying around and I didn't want to wait on saving money and ordering actual heat wrap for all the lines. Here in Virginia its in the high 90's everyday so I wanted something there for now. Once I get some money together I want to get precision coils and relocate them to the intake side to get all the wires away from that oven lol. Also going to order the vibrant heat sleaving for the oil feed and oil drain, and heat reflective sleeves for all remaining wires near the turbo/ exhaust.
2019_06_30_12_25_IMG_3012.JPG
2019_06_30_12_25_IMG_3013.JPG
 
  • 1Like
Reactions: doublespaces

doublespaces

Administrator
Oct 18, 2016
7,927
AZ
Welcome back! To pass emissions you need to get a dp fix and if you disabled the code in your flash you need to enable it again. I think you said you are JB4 and it has an auto clear I think so you may need to disable that so it can do its testing. In MHD there is a "stock downpipes" option or something along those lines.
 

Twisted Tuning

Lieutenant
Platinum Vendor
Oct 25, 2016
901
New York
If you're in Virginia, no DP fix is needed. At least from what their Site says. The normal one monitor not ready for 2001 and newer vehicles. But does not indicate that the Catalyst monitor not being ready (cali does this) is an auto fail. Only if the initial fail is for a Cat code, does the monitor need to be ready for the re-inspections.

If you're looking on the forums for answers to this. don't. Vehicle inspections are state specific. So read your states inspection sites.
 

markyb0

Specialist
Jun 17, 2017
96
Hampton, VA
Welcome back! To pass emissions you need to get a dp fix and if you disabled the code in your flash you need to enable it again. I think you said you are JB4 and it has an auto clear I think so you may need to disable that so it can do its testing. In MHD there is a "stock downpipes" option or something along those lines.
I don't think I've disabled any codes in my flash. Its just one of the base maps on mhd. I'll have to take a look at my mhd setup its been awhile but I'm pretty sure all I have checked is adv o2 option. I don't know about stock cats or not. And I think my auto delete is already off but I'll double check that. Thanks.

If you're in Virginia, no DP fix is needed. At least from what their Site says. The normal one monitor not ready for 2001 and newer vehicles. But does not indicate that the Catalyst monitor not being ready (cali does this) is an auto fail. Only if the initial fail is for a Cat code, does the monitor need to be ready for the re-inspections.

If you're looking on the forums for answers to this. don't. Vehicle inspections are state specific. So read your states inspection sites.
Just looked up the laws here in virginia and you are correct its 1 monitor fail only. I'm going to have to call a smog shop and ask because my car is still registered in cali since I'm military. I don't have to register it here. But if they auto fail for the catalyst i might just register it here in virginia so i can just get the 1 monitor fail.
 
  • 1Like
Reactions: JimboFresh206

JimboFresh206

Sergeant
Jan 29, 2018
270
here in Washington, different counties have different emissions standards, some with none at all.

might want to look into that in VA. See if you can set your mailing address to your current county, but the registration address to a non emissions (rural) county? (what we do here to get around it)

also can confirm my ADV's are working fine with just the MHD box checked, tuned by motiv :)
 
Last edited:

markyb0

Specialist
Jun 17, 2017
96
Hampton, VA
Sorry I haven't been on here been busy but since then I've talked to cali dmv and they didn't give me a direct answer about weather or not my car has to be smogged in the location I'm living in even though I'm military. They just said to send in a dmv form to register it and the paperwork they send me will tell me if I have to or not. I don't really like those odds because if I pay the $250 to register it and I don't get a waiver, the closest smog near me is 4 hours away and I'm not doing that lol. So I'm thinking about just registering it here in Virginia so I don't have to get it smogged and just need the state inspection and not waist my money and registering it twice. But before any of that I still need to replace the valve cover, rear tires and a alignment. Also just got several cyl misfire code and i checked the spark plugs and all of them are black. It hasn't really ran ran in a long time and also has some really old fuel so I'm going to put some new 93 in and injector cleaner see if that changes anything. Wish me luck.
 

markyb0

Specialist
Jun 17, 2017
96
Hampton, VA
Update: Got some royal purple injector cleaner in and some fresh 93 and seems to be running a lot smoother at start up. haven't checked the plugs yet but hopefully they look better. I'm planning on putting some ngk's in anyway after I replace the valve cover. While im in the head this time I'll plug the pcv ports so I'll finally have a full pcv system. Also when I got back from the gas station I checked for any codes and I think my fuel pump is slowly going bad or my ekpm3 module is going bad. I keep getting 2AAF fuel pump plausibility and 2FBD fuel high pressure nach. Seen some post of people buying some used ones off ebay for $50 and coded it and it worked so I think that's what I'm going to do for now as a quick fix. I don't have the money to cough up 330 for a new one or 700 for a eo one. Still in the process of getting it registered but hopefully it'll be done in the next week or two and the valve cover will be in by next weekend and I should be back on the road sometime august. Its been way to long since I've gotten to drive this beast.
 

markyb0

Specialist
Jun 17, 2017
96
Hampton, VA
Ordered my valve cover and also some injector seals. I noticed a couple spark plugs smelled like fuel so I think I got some leaky injectors. I know I did a stupid thing and just replaced them with some shitty ebay ones for a couple hundred bucks. Don't have the money to fork over $1200 for some index 12's so im just going to see if replacing the seals and decouplers will do the trick. I'm not getting misfires in any cylinder except cyl 3 and there was a lot of oil on the plug so I think the valve gasket is leaking into it. We will see this weekend if the new valve cover solves my smoking coming from the headers and oil in the plugs.
 

markyb0

Specialist
Jun 17, 2017
96
Hampton, VA
On the decouplers.do they actually go bad?What can go wrong with them?I did change them with new injectors as its the rule anyway.
I don't know if they go bad or not. I just know that those seals are one time use and the seal and decoupler are only $2 a piece so might as well just replace them as well. Hoping that the seals are just bad not my injectors which they probably are bad since they some cheap refurbished ones from ebay.
 

Weehe

Specialist
May 21, 2019
68
The seals and decouplers have 0 effect if the injector is leaking. Not sure the thought process here.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Top