N55 / S55 6MT WG delay causing lag between shifts?

Nezil

New Member
Apr 12, 2020
1
I hope I’m posting in the correct place ;this is my first post on Spoolstreet. I normally post on Bimmerpost, but every search I did on N55 tuning seemed to turn up a thread here, so I’m hoping this might be the best place to get some help.

I have an N55 M2, and I’m currently running FBO with 50:50 WMI (Aquamist), allowing me to safely run the BM3 93 AKI OTS Stage 2 map with the crappy Califronia 91 pump gas we have here.

One of the things that has always bothered me about the way the M2 drives, is the lag between shifts, and the fact that there is minimal lag when shifting above 6,500 rpm made me start investigating why there is such a large amount of lag if shifting lower than this.

I should point out that my car is 6MT, and I’m very aware that DCT cars don’t have this lag because they can keep on the gas constantly, and don’t have to let off to change up gears like 6MT requires.

I’ve been capturing and looking at logs, and noticed that the WGDC doesn’t go back to 100% for quite some time (up to 1.5 seconds) even though boost is lost and therefore well below target after a shift. As soon as the waste-gate closes, boost rapidly builds and you can feel this when driving and even as a passenger. My research so far shows that shifting quicker makes this delay worse, not better, and the only thing that improves it is shifting quickly at higher RPM so that boost doesn’t have time to drop too much, and even at 80% wgdc, boost builds fast enough that you don’t feel as much lag.

I’ve reached out to ProTuning Freaks about this, and they did give me some new maps to try which partially improved the situation, but they seem to have given up at this point, and keep coming back to common arguments like ’DCT is quicker’, or ‘Shift at high RPM and it’s not an issue’, but I’d like to understand if there is some way that this behaviour can be tuned out.

I did reach out to NVM about this issue, and they responded that they do have a solution, but they’re unwilling and / or unable to do remote tuning from the UK to the US, so I’m left with a carrot dangling that there might be a solution... but don’t know what it is.

With that in mind, I’m looking to see if it’s possible to start modifying the stock WG behavior to see if I can find a solution. If I‘m able to find something, I can feed this info back to ProTuning Freaks and maybe it can be incorporated into the OTS maps. In order to do this, I need to better understand the tables that can be adjusted that affect WG behaviour. Is there anyone on this forum that can help with that, or would be open to discussing it?

Obviously I can provide links to logs and analysis about this.

Thanks in advance!
 
  • 1Like
Reactions: doublespaces

doublespaces

Administrator
Oct 18, 2016
8,793
AZ
Welcome and sorry for the shitty response time. I moved your thread to the N55 section where you'll get more eyeballs.

If you have a manual, you've got shift bog it sounds like. I suspect it afflicts the N55 as well. For the N54, there is a shift bog fix, do have access to MHD?
 

KevinC39

Corporal
Jun 27, 2017
212
Unfortunately I don't have an answer for you as I feel like I have a similar problem. I have a bigger turbo and a custom tune but something is still going on that's causing some slow response.

I'm not a log reading expert but I'd post what you have. There's several guys in here that seem to know what they are looking at.
 
  • 1Like
Reactions: doublespaces

Similar threads


Top